Tuesday, September 24, 2013

Worst screw up ever- my fault guys.

  This post is a direct apology to all the people I have been ignoring.  It seems that when I built the web site I made one massive error. The contact us button went no where.

  This is a major screw up. There are e-mails and contact us crap all over the place and I got them all to go to me. Except perhaps the most important, the big one right on the web page. It was bouncing everything.  I kept getting orders and inquiries, and messages so I figured everything was working fine. Until someone told me it was not, and I went in and saw almost a years worth of messages.

Damn.  I really need to contact a web master.

 Anyhow, here are some pics of the sprue not assembled. This will most likely never be for sale, I am already working on something better.

  Other than that, I have been busy connecting with folks. I have some creative help now and we have worked out an agreement on royalties. Look for some stuff pretty soon.

  Right now I am feeling pretty frustrated about one tiny little setting causing tons of messages to vanish. I read a few of them on the server  and frankly I could not have done half the work people were asking. But still it was rude as hell of me to not get and answer the message.

  One part of doing it yourself is admitting you suck at several parts of it.
. I am slowly working on shifting away from  widgets and in to stuff I like but that is going to take a little while longer.

  In any event, enjoy the fall and look for some new stuff someday

1 comment:

  1. Good to know about the Contact us not working. I had sent you a message a couple months back asking about making 40x75mm pill shaped bases and when I got no reply I figured you were just really busy.